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Chapter 1: Overview 

TagPro is a desktop application that takes acoustic-tag event data and creates an output file 
of capture/detection histories used for survival analysis by Program ATLAS or other software. 

Below is an image of the TagPro user interface at startup (Figure 1). 

Figure 1. The main TagPro user interface window at startup 

There are four main tabs—“Data,” “Release,” “Sites,” and “Files” —where the primary work 
is done. The user presses the gear icon in the upper left to execute user-defined runs. At startup 
before any data are loaded, only the Data tab is available.  

There is also a main menu bar above the gear icon across the top. The only functionality in 
that menu not available elsewhere is the “Clear All” command under “Data.” This function clears 
all input data, and the TagPro application will revert to its initial startup configuration. Because this 
command is potentially destructive, if the user selects it, a warning appears that allows the user to 
cancel that choice. 
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The user must take the following steps in TagPro to create an output file: 

1. Load the input data
2. Define the release groups
3. Define the sites
4. Define the runs
5. Execute the runs

The following chapters of this manual cover each of these steps.
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Chapter 2: Load the Input Data 

In order to begin loading input data into TagPro, the user must first specify the data folder 
where the input data files are stored. Three files are required for TagPro: (1) tag release information, 
(2) detection node and array site information, and (3) validated detection event information. Format 
and required data for each are documented in Appendix A. These files must use the file names 
listed here:

• tags.csv
• nodes.csv
• events.csv

A “removals.csv” file detailing censoring events may also be used. 

The user also specifies the output folder location. Once these folders have been selected, 
TagPro will remember the locations on subsequent runs. The user can then load the data using the 
“Load” button (circled in Figure 2). TagPro displays the status of the load process in the status 
window.  

Figure 2. Loading input data and selecting an output folder in TagPro via the “Data” tab 
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A pop-up window will appear once data have been successfully loaded (Figure 3). 

Figure 3: The confirmation popup in TagPro after data have been loaded 

Unsuccessful loads may occur if the required files are missing, incorrectly named, lacking 
required columns within the files, or if the data are incorrectly formatted. The most common of 
these issues is the data format for date-time, as Excel is often used to view or edit these files and 
defaults date-time objects to an incorrect format. The next section describes common fixes for this 
issue. 

Date and Time Format 

TagPro accepts two types of date and time format in the input files and provisionally a third 
format: 

1. yyyy-mm-dd hh:mm:ss: (e.g., 2021-03-15 03:00:15; the default format, and the format 
required by previous versions of TagPro)

2. mm/dd/yyyy h:mm:ss: (e.g., 3/15/2021 3:00:15)

If an input .csv file is edited and saved in Excel, the date and time fields will be saved by
default with the format mm/dd/yyyy h:mm (e.g., 3/15/2021 3:00). This is the same as the second 
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format above without the seconds. If the user loads a data file with date and time in this format, an 
error displays in the status window (Figure 4). TagPro is warning the user that the lack of seconds 
on the date and time records can negatively impact the precision of estimates. The third provisional 
format can be set if the user chooses to accept this condition and then checks the “Allow times 
without seconds” option in the Settings menu (Figure 5). If the user turns this option on, a warning 
dialog again appears, warning the user of a loss of precision. If the user accepts this warning, the 
input files can then be loaded with the date and time records in the default Excel format. 

When TagPro is terminated and subsequently restarted, it will revert to not allowing times 
without seconds. 

Figure 4: The warning generated when an input file lacks seconds in a date and time record 

Figure 5: The “Allow times without seconds” option in the “Settings” menu 
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Chapter 3: Define the Release 
Groups 

After loading the data, the user can select the “Releases” tab to define the releases (Figure 
6). The top section, labeled “Available Release Groups,” shows all releases from the tags input file 
as defined by release location, species, and tag year. The bottom section shows the releases defined 
by the user. The user can define releases in one of two ways: 

1. Select one or more of the available releases and press the “Bulk Add” button to add
themto the “Releases” window in the bottom section.

2. Select one or more of the available releases to combine into one release. In this case
theuser can accept the default name (the release names are hyphenated) or edit the
releasename in the “Release Name” box and press “Create.”

Figure 6. The TagPro “Releases” tab 
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Selecting “Bulk Add” allows the user to create a large number of release groups where each 
line represents an individual release. Selected groups are highlighted in blue (Figure 7). Added 
releases appear in the lower “Releases” window (Figure 8) and are available for further processing 
in TagPro. 

Figure 7. Using “Bulk Add” to define releases 

Figure 8. Releases added using “Bulk Add” 
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Alternatively, the user can combine releases into larger groups. In this example, rather than 
treating the wild and hatchery tagged groups as individual releases, two releases can be pooled into 
one by selecting them both in the “Available Release Groups section”. The default group name can 
be simplified. Below we changed the combined group to “RI Tailrace all species” (circled, Figure 
9), and then pressed the “Create” button, with the result shown in Figure 10. 

Figure 9. Create a release using the “Create” button 

Figure 10. New releases created by combining two releases
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Chapter 4: Define the Sites 

The user selects the “Sites” tab to define detection sites. The top section, “Available Arrays,” 
shows the locations available as defined in the nodes input file (Figure 11). The user then defines 
sites in the same way that releases are defined as described in the previous section, in that each line 
can be created as an individual site using “Bulk Add” or pooled by highlighting multiple sites and 
using “Create.” 

Figure 11. The “Sites” tab for setting sites 

9



In the below example (Figure 12), the user selected the first three arrays (RIBZ, RIFB, and 
RIDF), pressed “Bulk Add,” then selected the final two arrays (CBAR and SLND), renamed the 
site “Final,” and pressed “Create.” 

Figure 12. The “Sites” tab with user-defined sites 
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Chapter 5: Define the Runs 

Once the user has defined the releases and sites, they can define the output runs of detection 
histories. Runs are defined by:  

1. the desired output format (“ATLAS” or “Standard”)
2. the selected release(s)

3. the selected sites

To define a run, the user must go back to the Data tab (Figure 2) and press the “Add

Run”
button, bringing up the “Add Run Definition” dialog (Figure 13). The user gives the run definition 
a name (“TagPro example” in this case) and selects an output format (“ATLAS “or “Standard”). In 
the case below, the user has selected ATLAS. The user then presses “Next.” Refer to Appendix B 
for a description of the two types of output files. 

Figure 13: The “Add Run Definition” dialog for naming and selecting output format 

The Next button brings up the “Release Group Selection” dialog (Figure 14). Here the user 
selects one or more release groups. In this example the user has selected “RI Tailrace all species.” 
The user then presses Next for the “Sites Definition” dialog (Figure 15). In the Figure 15 example, 
the user has selected all sites. 
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Figure 14: The “Release Group Selection” dialog for selecting releases 

Figure 15: The “Sites Definition” dialog for selecting detection sites for run definition 

After pressing the Next button, the run definition summary appears (Figure 16). At this point 
the user can either press “Back” to modify the run definition, or “Finish” to complete the run 
definition.  
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Figure 16: The “Run Summary” definitions including Name, Format, Releases, and Sites 

The run is then displayed as shown below (Figure 17).

Figure 17: The “Data” tab with one run defined 
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Chapter 6: Execute the Runs 

Once runs have been defined, the final step is to select the desired runs (individually or 
multiple—each run will be saved individually). In our example, the user has defined two runs and 
selected both (Figure 18). The user presses the gear icon to process the selected runs. Alternatively, 
select “Run” under the “File” menu. When the runs are processed successfully, the number of 
records written to the output files is recorded in the Status area and a “Run Complete” message 
appears (Figure 19). 

Figure 18: Two runs selected and ready to be processed 
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Figure 19: TagPro after processing the runs 

The resulting output files are placed in the specified output folder. The output file names are 
defined by the name of the run followed by the format of the run (Figure 20). 

Figure 20: Example of TagPro output files 
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Appendices 

Appendix A: Input file Formats 

The following shows the names of the required fields in each input file. The input files are 
comma separated value (.csv) files. The following required field names must be in the header of 
each file, but they can be in any order. Other fields are allowed to be present but they will be ignored 
by TagPro. 

For the tags.csv file, the italicized field names are output as part of the “Standard” format, but not 
the “ATLAS” format. They are optional, and if present, empty values are allowed. 

The field names are followed by their data type: 

tags.csv 
• tagger_name: text
• bucket: integer
• length: integer
• weight: real
• tag_code: text
• lot: integer
• species_code: text
• tag_date: datetime
• activation_date: datetime
• release_date: datetime
• release_location: text
• release_river_km: real
• mortality: integer (1 for mortality, 0 for not mortality)

nodes.csv 
• node_code: text
• deploy_date: datetime
• location: text
• river_km: real

events.csv 
• node_code: text
• tag_code: text
• first_datetime: datetime
• last_datetime: datetime

removals.csv 
• tag_code: text
• removal_date: datetime
• removal_river_km: real
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Appendix B: TagPro Output Files 

TagPro can produce two types of output files. 

1. The ATLAS format produces the required input format for Program ATLAS. It contains a 
fixed number of columns:

• release name
• lot
• tag code
• tag activation date and time
• tag release date and time
• site
• 1 for detected, 0 for not detected
• last detection date and time (if detected)

2. The Standard format has one row for each tag and, unlike the ATLAS format, has a variable 
number of columns depending on the number of detection sites. The columns for tagger name, 
bucket, etc., can be used to easily create optional attribute files for Program ATLAS. The first 
columns are:

• release name
• lot
• tag code
• tag activation date and time
• tag release date and time
• tagger name
• bucket
• length
• weight
• one field for each detection site with a “1” for detected, “0” for not detected
• two fields for detection site: the first detection date and time, and the last detection date 

and time

Appendix C: Customizing the Date and Time Format in Excel 

The following describes how to save a .csv file in Excel and preserve the seconds in date and 
time fields. 

Figure C1 shows a tags file in an Excel worksheet with the three date-time fields selected 
(tag_date, activation_date, and release_date). The user has right-clicked on the selected fields and 
is selecting “Format Cells…” from the context menu. 
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Figure C1: Formatting date-time fields in a tags file in Excel 

Figure C2 shows the resulting Format Cells dialog. The user selects “Custom” under 
Category, and under Type, enters “m/dd/yy h:mm:ss” and then presses OK. 

Figure C2: Excel Format Cells dialog 

Once this is done, when the user saves the .csv file, the seconds will be saved with the selected 
date-time fields. 
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